RubyGems 1.5.0 erschienen: Jetzt mit Ruby 1.9.2 Unterstützung

RubyGems ist in Version 1.5 erschienen und bringt nun endlich Unterstützung für Ruby 1.9.2 mit. Dieses Release behebt nun die Probleme die es in der vorherigen Version (rubygems 1.4) mit der aktuellen Ruby-Version gab.

Neben Bugfixes bringt diese Version auch einige Neuerungen und Verbesserungen mit.

  • Wie schon erwähnt Unterstützung für Ruby 1.9
  • Post-build hooks die ein „gem install“ abbrechen könnenl
  • Gem.find_files ist jetzt 40% schneller (on Ruby 1.9)
  • Bessere Fehlerausgabe für beschädigte/korrupte Gem Dateien (inklusive Pfad)
  • Neue Hilfe Dokumente zur Unterstützung von Ruby 1.9
  • gem update aktualsiert nicht mehr defaultmäßig und falscher weise RubyGems selber

Die Aktualisierung kann wie gewohnt über gem selber vollzogen werden:

 

[bash]
gem update –system
[/bash]

 

Alternative Installations- und Aktualisierungmöglichkeiten sind in der neuen Dokumentation verfügbar:

https://github.com/rubygems/rubygems/blob/master/UPGRADING.rdoc

 

Benutzer von Bundler sollten mit dem Update noch ein wenig warten, weil die atktuelle Bundler-Version nicht perfekt mit dem neuen RubyGems funktioniert. In der Regel sollte auch hier eine aktualisierte Version relativ schnell erscheinen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

This site uses Akismet to reduce spam. Learn how your comment data is processed.