Screencast: Bundler

Fast jede Rails/Ruby-Applikation hat Abhängigkeiten zu Bibliotheken und häufig auch zu einer bestimmten Version. Bundler kann solche Abhängigkeiten lösen und kann somit vieles vereinfachen. Ryan zeigt in dieser Woche wie Bundler eingesetzt werden kann.

 

Download:

Download (17 MB, 9:22)
Alternativer Download für iPod & Apple TV (11.7 MB, 9:22)

 

Resourcen:

 

Quellcode:

[bash]
gem install bundler
bundle install
bundle check
bundle help
bundle install –without=test
bundle lock
bundle install –relock
ls ~/.bundle
bundle pack
ls vendor/cache
[/bash]

[ruby]
gem "rails", "3.0.0.beta"
# gem "rails", :git => "git://github.com/rails/rails.git"

gem "sqlite3-ruby", :require => "sqlite3"

# gem "rspec", :group => :test
group :test do
gem "webrat"
end

gem "will_paginate", ">= 2.3.12"
[/ruby]

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

This site uses Akismet to reduce spam. Learn how your comment data is processed.